Düşey Ara Formülü

Önceki başlık Sonraki başlık Aşağa gitmek

Düşey Ara Formülü

Mesaj  aSk_iLe Bir Salı Nis. 13, 2010 8:11 pm

Soru:
Düşeyara formülünü uygularken, 2 şarta nasıl bağlayabiliriz?

örneğin birinci veri tabanımız aşağıdaki gibi olsun;
numarası - tarih - işlem
2024 - 1 ocak - x işlemi
2024 - 20 şubat - y işlemi
2025 - 10 ocak - x işlemi
2026 - 2 ocak - x işlemi

ikinci veri tabanımızda şöyle olsun (isimler ve bu isimlerle eşleşen numaralar)
numarası - adı
2024 - ali
2024 - ali
2025 - veli
2026 - ayşe


bu verilerden düşeyara ile isim ve numaraları eşleştiriyorum, ancak sadece x işlemini taşıyan numaraları eşleştirmek istiyorum ve aşağıdaki gibi bir tablo oluşturmak istiyorum;

adı- numarası - tarih - işlem (sadece x işlemleri)
ali - 2024 - 1 ocak - x işlemi
veli - 2025 - 10 ocak - x işlemi
ayşe - 2026 - 2 ocak - x işlemi

yardımınıza ihtiyacım var,
şimdiden teşekkür ederim.



Cevap
1. veri tabanınız Başlık 1. satırda olmak üzere A2,B2 ve C2 den itibaren,
2. veritabanınız Başlık 1. satırda olmak üzere D2 ve E2 hücresinden itibaren yerleşikse
F2 hücresine;
=EĞER(E2="";"";EĞER(C2="x işlemi";MAK($F$1:F1)+1;""))
formülünü uygulayıp aşağı doğru çoğaltın.
G2 hücresine; =EĞER($H2="";"";İNDİS($A:$F;KAÇINCI($H2;$D:$D;0);5))
H2 hücresine; =EĞER(SATIR()-1>MAK($F:$F);"";İNDİS($A:$F;KAÇINCI(SATIR()-1;$F:$F;0);1))
I2 hücresine; =EĞER(SATIR()-1>MAK($F:$F);"";METNEÇEVİR(İNDİS($A:$F;KAÇINCI(SATIR()-1;$F:$F;0);2);"gg.aaaa"))
J2 hücresine; =EĞER(SATIR()-1>MAK($F:$F);"";İNDİS($A:$F;KAÇINCI(SATIR()-1;$F:$F;0);3))
formüllerini uygulayıp aşağı doğru çoğaltın.
Eğer birleştirilmiş sonuç istiyorsanız K2 hücresine;
=EĞER(SATIR()-1>MAK($F:$F);"";İNDİS(A:F;KAÇINCI(İNDİS($A:$F;KAÇINCI(SATIR()-1;$F:$F;0);1);D:D;0);5)&" - "&İNDİS($A:$F;KAÇINCI(SATIR()-1;$F:$F;0);1)&" - "&METNEÇEVİR(İNDİS($A:$F;KAÇINCI(SATIR()-1;$F:$F;0);2);"gg.aaaa")&" - "&İNDİS($A:$F;KAÇINCI(SATIR()-1;$F:$F;0);3))
formülünü uygulayıp aşağı doğru çoğaltın.
İyi çalışmalar.
<alıntı>


ßæ
avatar
aSk_iLe

Mesaj Sayısı : 17
Rep gucu : 34
Kayıt tarihi : 08/04/10
Yaş : 49
Nerden : merKezdeN

Kullanıcı profilini gör

Sayfa başına dön Aşağa gitmek

Önceki başlık Sonraki başlık Sayfa başına dön

- Similar topics

 
Bu forumun müsaadesi var:
Bu forumdaki mesajlara cevap veremezsiniz